Admin Tools 2.2.0 (Stable)

Admin Tools 2.2.0 (Stable) is released.

We are pleased to announce the immediate availability of Admin Tools 2.2.0, the stable release of our new Admin Tools 2.2 series.

This release addresses minor functional and cosmetic issues discovered in the 2.2.a3 (Alpha) release and introduces new features. It is compatible with Joomla! 1.5 and 2.5. Using Admin Tools on Joomla! 1.6 and 1.7 is no longer supported.

IMPORTANT! If you are also using Akeeba Subscriptions 2.x on your site, please make sure that you have installed Akeeba Subscriptions 2.0 Stable or later before installing Admin Tools 2.0.a1 or later. Older versions of Akeeba Subscriptions can cause Admin Tools to fail and bring your site down.

Getting Admin Tools and receiving support

As always, you can download the free version, Admin Tools Core, from our Downloads page without any charge. If you are a Professional subscriber you can download the Admin Tools Professional release from the same page; just make sure you are logged in before visiting the download page. Alternatively, you can use the integrated Live Update feature of our software to update it automatically on supported server environments.

Since July 2011, support is provided only to subscribers. We have created a cheap (7.79€) subscription, MINISUPPORT, which gives you access to our Ticket System for eight days, with the same priority as all subscribers to any subscription level. If you have an active ATPRO susbcription you already have access to the support forum; you don’t need to buy a new subscription. Moreover, if you have an active AKEEBADELUXE or SUPPORT subscription you can get top priority, private support through our Private Ticket support system.

Do you want the maximum protection for your Joomla! site without spending a fortune? Admin Tools Professional can do that, with a flat cost of 20 Euros – or just 10, if you bought an AKEEBAPRO subscription the last three months. An ATPRO subscription allows you to use the component on as many sites as you want, for as long as you want (even after your subscription expires) and receive updates and support for a whole year. For the price of a cheap dinner you can get the maximum protection for all your Joomla! 1.5, 1.7 and 2.5 sites. Go Professional today!

Supported versions

Our support policy is to provide support only to the latest published stable release of Admin Tools, as well as to the latest published preview (alpha, beta or release candidate) release, if one is available. Furthermore, we will only support running our software on the latest published Joomla! version. Earlier Joomla! versions are vulnerable to security threats or buggy, therefore unsupported.

Moreover, we only support the Joomla! versions officially supported by the Joomla! project. Due to the plethora of active Joomla! versions, we have consolidated the support terms for different Admin Tools and Joomla! version combinations in the table below: 

Joomla! 1.5.15 or later

Joomla! 1.6, 1.7

Joomla! 2.5

Admin Tools 2.2.x *

 Until April 1st, 2012 

 Not supported 

 Until August 2013 ** 

Older releases

Not supported

* Only the latest Admin Tools 2.2.x release is supported. At the time of this writing, this is version 2.2.0

** If a new Admin Tools series (e.g. 2.3.x or 3.x) is released before August 2013, Admin Tools 2.2.x will cease being supported, per our support policy stated above.

Rolling back to an earlier Admin Tools version

If you accidentally installed Admin Tools 2.2.0 on a live site with an unsupported Joomla! version, you will have to roll back to the last version supporting your platform (e.g. Admin Tools 2.1.14 for Joomla! 1.7 sites). If this is the case, do not uninstall Admin Tools! If you do that, you will lose all of your settings, including .htaccess Maker, Web Application Firewall and IP White-/Black-lists. Also you MUST NOT install an earlier version of Admin Tools on top of any 2.2.x version, as this could cause grave issues. If you want to downgrade, please follow the procedure below:

Using an FTP programme, please remove the following files and directories, in the order outlined below:

plugins/system/admintools.php (Joomla! 1.5 only)

plugins/system/admintools

plugins/system/atoolsjupdatecheck.php (Joomla! 1.5 only)

plugins/system/atoolsjupdatecheck (Joomla! 1.7 only)

plugins/system/atoolsupdatecheck.php (Joomla! 1.5 only)

plugins/system/atoolsupdatecheck (Joomla! 1.7 only)

administrator/modules/mod_atjupgrade

components/com_admintools

administrator/components/com_admintools

Then, please download the ZIP package of an earlier Admin Tools release, compatible with your Joomla! version, from our Downloads area and install it on your site. After the installation you might see that the update notification icon (UPDATE FOUND) in Admin Tools' Control Panel page. Please ignore it. Using it will upgrade Admin Tools to the latest published 2.2.x release which could break your site again.