Downloads

Akeeba Backup for Joomla!

Akeeba Backup for Joomla!

version 4.3.0 Stable

Released on: Wednesday, 05 August 2015 06:39

Release Notes

Release highlights

Archive integrity check. When you enable this optional feature Akeeba Backup will try to perform a dry-run extraction of the backup archive (extract without writing anything to disk) after the backup is complete and before transferring the backup archive to remote storage. This allows you to be confident that your backup archive is not corrupt. Please note that this feature cannot not check if your site restores successfully as this depends on the PHP and MySQL version and configuration of your target server as well as any reconfiguration which might be necessary in third party extensions. This feature will only make sure that you don't end up with a broken backup archive that cannot be extracted.

Joomla! 3.3/3.4 only

Only Joomla! 3.3 and 3.4 (and 3.5 which is planned for release in a couple of months) is supported by this version. We strongly recommend using the latest Joomla! At the time of this writing it is 3.4.3. Using older versions is NOT recommended for security reasons.

PHP 5.4 or later 5.x version is required

We have raised the minimum PHP version requirement to 5.4.0 in this version. Even though the component might work on PHP 5.3 we have no tested it with it and we will not support it. We'd like to remind you that Joomla! 3.x does not currently support PHP 7. Since our software runs inside Joomla! by definition our software doesn't currently run on PHP 7 either.

Note: there is no such thing as PHP 6. PHP versions jumped from 5.6 to 7.0. Why? Well, it's a long story. TL;DR: It doesn't have to make sense, just accept it.

Changelog

Bug fixes

  • [HIGH] Multipart ZIP archives were broken
  • [LOW] Fixed profile description tooltip
  • [LOW] The SQL query would not be printed on database errors
  • [LOW] The autoupdate script could not download the package in PRO versions
  • [MEDIUM] ANGIE: You could not override the ANGIE password in the Backup Now page

New features

  • ANGIE: Added option to enable/disable mail system while restoring a Joomla site
  • Automatically check the integrity of the backup archive (opt-in, please read the documentation)

Critical bugs and important changes

  • Minimum PHP version required is now 5.4.0

Our Core versions are provided free of charge,
but they only scratch the surface of what's possible.

Subscribe today to get access to the exclusive features and enhanced support of our Professional releases!

Subscribe and get full access!

Already a subscriber? Log in.