Downloads

Akeeba Backup for Joomla!

Akeeba Backup for Joomla!

version 8.0.13 Stable

Released on: Thursday, 18 November 2021 05:46

Release Notes

What's new

Dropbox connector updated to require TLS v1.2. Starting February 1st, 2022 the Dropbox API will require that calls use TLS 1.2. Traffic using TLS 1.0 or 1.1 will be rejected. The code in our backup engine has been updated to require TLS v1.2 as long as your server has the PHP cURL extension compiled against libcurl version 7.34.0 or later. If uploads to Dropbox fail after February 1st, 2022 you will need to ask your host to upgrade your hosting environment with software that was released after December 17th, 2013 — yes, the minimum requirement is for software released 8 years ago, a lifetime in computer terms and not unreasonable at all!

Removed the “Archive integrity check” feature. This feature had a very limited utility as it would only work if you would not upload backup archives to remote storage or, if you did, that you did not upload each part file as soon as it was created. Moreover, it could enter an infinite loop in some circumstances which could create a confusing backup experience. Even without these problems it could not guarantee that you had a backup that can be restored, just that you have a backup archive that can be extracted. Whether you had accidentally excluded critical data necessary for restoring your site was beyond what it could check. Seeing that its utility was so limited we decided to remove it altogether instead of spending more time to work on its (rather rare) issues. Our time is best spent creating and improving features that make sense.

Dropbox connector updated to require TLS v1.2. Dropbox communicated to us that starting February 2022 it will require TLS v.1.2 or later when using its APIv2. While our code would automatically use the highest available version of TLS supported by your server and Dropbox itself, it would not check whether your server supported at least TLS v.1.2. This is not checked and will result in an error if your server does not meet Dropbox' minimum requirement.

Bug fixes and minor improvements. Please take a look at the CHANGELOG below.

Joomla! and PHP versions supported

Please consult our Compatibility page. It explains our version support policy and lists which versions of our software are compatible with which versions of Joomla and PHP.

Changelog

Removed features

  • Removed iDriveSync; the service has been discontinued by the provider.
  • Removed the “Archive integrity check” feature.

Bug fixes

  • [LOW] Check failed backups: All Super Users were notified even when an email was supplied

Miscellaneous changes

  • Dropbox connector updated to require TLS v1.2
  • Improved the display of the files and folders filters page

Our Core versions are provided free of charge,
but they only scratch the surface of what's possible.

Subscribe today to get access to the exclusive features and enhanced support of our Professional releases!

Subscribe and get full access!

Already a subscriber? Log in.