This version requires PHP 5.3, 5.4, 5.5 or 5.6. The rationale behind this is explained in our statement of mid-February 2013. It won't install on hosts running PHP 5.2 or earlier. PHP 5.3.4 or later is required, due to show-stopper bugs in earlier versions of PHP 5.3. Important note on reading PHP versions: PHP 5.3.20 is newer than 5.3.10 which is newer than 5.3.4. Moreover, PHP 5.4.0 is newer than PHP 5.3.4.
Use on PHP 7.0 is only supported on Joomla! 3.5. Earlier Joomla! versions do not run on PHP 7.
This version of our software can be installed on Joomla! 3.4.x or 3.5.x. We always recommend that you should use the latest Joomla! 3 release available from Joomla.org.