Downloads

Official Releases

Akeeba Release System

version 2.4.0 Stable

Released on: Thursday, 17 July 2014 11:35

Release Notes

Release highlights

Improved Download ID management. In previous versions the Download IDs were linked to the (hashed) password and the email address of the user. As a result, whenever the user changed / reset their password, changed their email address or whenever Joomla! would change the hashing method of the passwords all Download IDs, main and add-on, would change. Joomla! has already changed the password hashing method twice in 6 months leading to much frustration among users because they had to change their Download IDs on all of their sites. This version deals with this issue by creating random Download IDs and storing them in the database. The Download IDs do not change unless the user specifically asks a Download ID to be reset. For backwards compatibility reasons, existing users are assigned a Download ID which is identical to what they would use with ARS 2.3.0 and earlier. The switchover to the new version will be transparent to your clients.

Removed support for PostgreSQL. Joomla!'s integration with the PostgreSQL database server is broken for nearly a year. Since it is impossible to use Joomla! on PostgreSQL we cannot test our software against that database server (let alone proving that nobody uses Joomla! on PostgreSQL...). As a result we dropped PostgreSQL support and will not be pursuing this integration in future versions.

PHP 5.3, 5.4 or 5.5 is required

This version requires PHP 5.3, 5.4 or 5.5. The rationale behind this is explained in our statement of mid-February 2013. It won't install on hosts running PHP 5.2 or earlier. PHP 5.3.4 or later is required, due to show-stopper bugs in earlier versions of PHP 5.3. Moreover, due to the necessary Joomla! API changes found only in Joomla! 2.5.6 or later, this version will not install on Joomla! 2.5.5 or earlier versions. In any case, it will tell you exactly why it cannot be installed (minimum PHP or Joomla! version not satisfied).

Joomla! 2.5, 3.2, 3.3 are supported

This version of our software can be installed on Joomla! 2.5.6 or any later 2.5.x release, as well as any 3.2.x or 3.3.x release. It is not compatible with Joomla! 3.0 or 3.1. These versions of Joomla! are old and vulnerable. If you are using them please upgrade to the latest Joomla! 3 release available from Joomla.org.

Changelog

New features

  • Improved Download ID management: Download IDs no longer change when the password is changed / reset / rehashed

Our Core versions are provided free of charge,
but they only scratch the surface of what's possible.

Subscribe today to get access to the exclusive features and enhanced support of our Professional releases!

Subscribe and get full access!

Already a subscriber? Log in.