Support

Admin Tools for WordPress

#34054 – Woo app by Wordpress.com cannot access site

Posted in ‘Akeeba Admin Tools for WordPress’
This is a public ticket. Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.
Tuesday, 17 November 2020 07:29 CST
GeertF

Good afternoon,

I have a webshop using Woocomerce under WP. We like to use a app from Woocommerce, that allows to manage the shop in the admin side.

I noticed that when I disable the Admin Tools, the app canenter the site and works fine. But when I enable AdminTools the app gives a warning that it doesn't have (good) access to the site.

All settings are default. I only use a diferent URL voor admin.

Any thoughts?

Tuesday, 17 November 2020 09:06 CST
tampe125

Hello,

can you please take a look at the Security Exception page and see if you recognize an URL pointing to WooCommerce?

What's the reason for the block for such entry?



Davide Tampellini

Developer and Support Staff



Italian: native

English: good



Please keep in mind my timezone and cultural differences when reading my replies. Thank you!



Tuesday, 17 November 2020 11:44 CST
GeertF

Thank you for your reply,

I found a few like this in the log:

(I changed the token for security reasons):

2020-11-17 13:09:57   192.0.101.17 COM_ADMINTOOLS_LBL_SECURITYEXCEPTION_REASON_DFISHIELD https://queijodocampo.pt/?rest_route=/&_method=get&_fields=authentication,namespaces&_for=jetpack&token=XXXXXXXXzuQ((^CVZ)QPO2!JD7fJxOM:1:1×tamp=1605618597&nonce=yOA8IQtYZ6&body-hash&signature=opSR+Kop//XXXXXXXvGJJpkqSXk=                  

 

Wednesday, 18 November 2020 04:11 CST
tampe125

mhm.. that's a bit strange, since we removed the DFI feature to prevent issues exactly like that.

Can you please double check that you have the latest version of Admin Tools? After that, can you please double check that the file app/plugins/waf/feature/dfishield.php no longer exists inside plugin path?



Davide Tampellini

Developer and Support Staff



Italian: native

English: good



Please keep in mind my timezone and cultural differences when reading my replies. Thank you!



Wednesday, 18 November 2020 04:59 CST
GeertF

Good morning Davide,

Yesterday evening I did another test with disable/enable the plugin. After that there was an update notification (before it wasn't). So I did the update.

When I search now for the .php file, I don't see it.

And the problem seems to be solved as well.

Thank you for your time!

Best regards from a happy customer,

Geert Franken

Spoton Webdesign

Wednesday, 18 November 2020 05:25 CST
tampe125

You're welcome, I'm glad your issue has been fixed.



Davide Tampellini

Developer and Support Staff



Italian: native

English: good



Please keep in mind my timezone and cultural differences when reading my replies. Thank you!



Friday, 18 December 2020 20:17 CST
system
This ticket has been automatically closed. All tickets which have been inactive for a long time are automatically closed. If you believe that this ticket was closed in error, please contact us.
This ticket is closed, therefore read-only. You can no longer reply to it. If you need to provide more information, please open a new ticket and mention this ticket's number.