#33727 – Installation uses database table backup solo_ when prefix field is left blank

Posted in ‘Akeeba Solo (standalone)’
This is a public ticket. Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.
Wednesday, 16 September 2020 14:58 CDT
patgaytx

When installing, I kept getting weird database connection errors.  I finally figured out that I intentionally removed the value from the database table preview field, because I didn't want to use one.  When I looked in the config.php, it indeed showed "prefix": ""

When I looked at the database tables, though, all the tables started with solo_. I changed the config.php to be "prefix": "solo_" and all of the problems went away.

Not sure what happened, but it appeared that the web installer took the prefix field being blank to mean use the default of solo_.

Thanks
Patrick

Custom Fields

PHP version (in x.y.z format) 7.4.10
Akeeba Solo version (x.y.x) 7.3.0
Thursday, 17 September 2020 07:33 CDT
tampe125

Hello,

this is intentional. Akeeba Solo will not work without a prefix. So if you try to give it no prefix which would make it fail it defaults to solo_.

In this way we can prevent unexpected results if your database has some tables with the same names as Akeeba Solo ones.



Davide Tampellini

Developer and Support Staff



Italian: native

English: good



Please keep in mind my timezone and cultural differences when reading my replies. Thank you!



Thursday, 17 September 2020 08:17 CDT
patgaytx

I would suggest adding some text to the documentation that explicitly states that a prefix is required.  Currently, the documentation makes it sound like it's optional. Yes, it says it has to be 2 to 4 characters, but that doesn't mean it's required, the way it's worded currently appears to only apply to the requirements of the prefix, IF, you were to use them.

This is the common prefix of all database tables used by Akeeba Solo. It has to be two to four characters a-z and numbers 0-9 followed by an underscore. If you are unsure, use the default value of solo_

Thursday, 17 September 2020 08:39 CDT
tampe125

Thanks for the suggestion, I'll do that right now



Davide Tampellini

Developer and Support Staff



Italian: native

English: good



Please keep in mind my timezone and cultural differences when reading my replies. Thank you!



Sunday, 18 October 2020 01:17 CDT
system
This ticket has been automatically closed. All tickets which have been inactive for a long time are automatically closed. If you believe that this ticket was closed in error, please contact us.
This ticket is closed, therefore read-only. You can no longer reply to it. If you need to provide more information, please open a new ticket and mention this ticket's number.

Support Information

Working hours: Typically we work Monday to Friday, 9am to 7pm Cyprus timezone (EEST). Support is provided by the same developers writing the software, all of which live in Europe. You can still file tickets, but we cannot respond to them, outside of our working hours.

Support policy: We would like to kindly inform you that when using our support you have already agreed to the Support Policy which is part of our Terms of Service. Thank you for your understanding and for helping us help you!