#33834 – backup failed to end

Posted in ‘Akeeba Solo (standalone)’
This is a public ticket. Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.
Saturday, 03 October 2020 08:31 CDT
richardball

This is the third time I have used Akeeba Solo for this website - it is a Zenphoto installation with many pics - backup is around 8 or 9 GB. First two backups went fine. 

Today the backup went on for 3 or 4 hours, mostly on the last section, can't remember its exact name, something like backup done finishing up - it kept indicating access to the disk 1 sec, 0sec etc. 

I eventually stopped it about 15.50 (website time)

The log file looks as though it finished properly but it never returned, just kept on going:

--- START OF RAW LOG ----- START OF RAW LOG --DEBUG   |201003 09:37:19|*** Batching successive steps (nesting level 1)DEBUG   |201003 09:37:19|====== Starting Step number 1 ======DEBUG   |201003 09:37:19|Kettenrad :: Switching domainsDEBUG   |201003 09:37:19|Kettenrad :: BREAKING STEP BEFORE SWITCHING DOMAINDEBUG   |201003 09:37:19|Switching to domain init, class InitDEBUG   |201003 09:37:19|Akeeba\Engine\Core\Domain\Init :: New instanceDEBUG   |201003 09:37:19|Kettenrad :: Ticking the domain objectDEBUG   |201003 09:37:19|Kettenrad :: Domain object returned without errors; propagatingDEBUG   |201003 09:37:19|Kettenrad :: Break flag status: YESDEBUG   |201003 09:37:19|----- Finished operation 1 ------DEBUG   |201003 09:37:19|Successful Smart algorithm on Akeeba\Engine\Core\Domain\InitDEBUG   |201003 09:37:19|====== Finished Step number 1 ======

DEBUG   |201003 13:02:00|*** Batching of engine steps finished. I will now return control to the caller.DEBUG   |201003 13:02:00|*** Batching of engine steps finished. I will now return control to the caller.DEBUG   |201003 13:02:00|*** Batching of engine steps finished. I will now return control to the caller.DEBUG   |201003 13:02:00|Sleeping for 1990.7832145691 msec, using usleep()DEBUG   |201003 13:02:02|Saving Kettenrad instance backendDEBUG   |201003 13:02:02|Kettenrad :: Attempting to load from database (backend) [backend.3]DEBUG   |201003 13:02:02| -- Loaded stored Akeeba Factory (backend) [backend.3]DEBUG   |201003 13:02:02|====== Starting Step number 4483 ======DEBUG   |201003 13:02:02|Kettenrad :: Ticking the domain objectDEBUG   |201003 13:02:02|Akeeba\Engine\Core\Domain\Finalization::_run() Running built-in method update_statisticsDEBUG   |201003 13:02:02|Updating statisticsDEBUG   |201003 13:02:02|Kettenrad :: Domain object returned without errors; propagatingDEBUG   |201003 13:02:02|Kettenrad :: Break flag status: YESDEBUG   |201003 13:02:02|----- Finished operation 1 ------DEBUG   |201003 13:02:02|Successful Smart algorithm on Akeeba\Engine\Core\Domain\FinalizationDEBUG   |201003 13:02:02|Kettenrad :: More work required in domain 'finale'DEBUG   |201003 13:02:02|====== Finished Step number 4483 ======DEBUG   |201003 13:02:02|Kettenrad :: Setting the break flag between domainsDEBUG   |201003 13:02:02|*** Engine steps batching: Break flag detected.DEBUG   |201003 13:02:02|*** Batching of engine steps finished. I will now return control to the caller.DEBUG   |201003 13:02:02|Sleeping for 1990.061044693 msec, using usleep()DEBUG   |201003 13:02:04|Saving Kettenrad instance backend--- END OF RAW LOG ---

I can attach the zipped file if you wish but it is 91mb in size. 

Should this happen again how can I tell if has actually finished or not?

The Akeeb Solo home page describes it as 'failed' - how can I tell if that is really the case or not? 

Thanks, 

Richard

 

Custom Fields

PHP version (in x.y.z format) 7.3
Akeeba Solo version (x.y.x) 7.3.1
 
Sunday, 04 October 2020 23:17 CDT
nicholas

This is a very rare issue introduced in the 7.3.1 release. It only happens when the database server drops the MySQL connection after a very short period of inactivity (under 2 seconds) which makes this issue rare and impossible to test – the latter because testing is very sensitive to timing which cannot be reproduced reliably in automated testing.

I have identified the issue and tested a solution with 5 different affected servers. It works with all of them.

I am going to release a new version of Akeeba Backup pretty much as soon as I finish replying to tickets about this issue. You will see a new update later today. Please install it. It will fix this issue.



Nicholas K. Dionysopoulos

Lead Developer and Director



🇬🇷Greek: native

🇬🇧English: excellent

🇫🇷French: basic



Please keep in mind my timezone and cultural differences when reading my replies. Thank you!



Wednesday, 07 October 2020 04:51 CDT
richardball

Thank you for your prompt response. This is presumably Akeeba solo version 7.3.2 ?

Richard

 
Wednesday, 07 October 2020 08:15 CDT
nicholas

Correct. This is the new version which addresses this issue.



Nicholas K. Dionysopoulos

Lead Developer and Director



🇬🇷Greek: native

🇬🇧English: excellent

🇫🇷French: basic



Please keep in mind my timezone and cultural differences when reading my replies. Thank you!



Saturday, 07 November 2020 01:17 CST
system
This ticket has been automatically closed. All tickets which have been inactive for a long time are automatically closed. If you believe that this ticket was closed in error, please contact us.
This ticket is closed, therefore read-only. You can no longer reply to it. If you need to provide more information, please open a new ticket and mention this ticket's number.

Support Information

Working hours: Typically we work Monday to Friday, 9am to 7pm Cyprus timezone (EEST). Support is provided by the same developers writing the software, all of which live in Europe. You can still file tickets, but we cannot respond to them, outside of our working hours.

Support policy: We would like to kindly inform you that when using our support you have already agreed to the Support Policy which is part of our Terms of Service. Thank you for your understanding and for helping us help you!