#35390 – No Modal in instant replies and non editable message textarea

Posted in ‘Akeeba Ticket System’
This is a public ticket. Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.
Tuesday, 15 June 2021 08:19 CDT
sakis

Hi

 

I updated my ticket system from an old one and during the testing i confronted 2 issues:

1. Pressing the "View" button in instant replies does not load a modal window with the selected ticket.

See the related screencast: https://www.awesomescreenshot.com/video/4136013?key=801b3a742243e88eb07221ddbf1a98cc

 

2. The message textarea is missing the editor is not editable.

See the related screencast: https://www.awesomescreenshot.com/video/4136059?key=b6a43a17bff654bb957290bfefdfffd0

 

I visited the instant replies plugin. It is enabled and saved it again, just in case.

Your help is really appreciated.

Kind regards,
Sakis

Custom Fields

Joomla! version (in x.y.z format) 3.9.27
PHP version (in x.y.z format) 7.2
Akeeba Ticket System version (x.y.z format) 4.0.2
 
Tuesday, 15 June 2021 08:38 CDT
sakis

I am also attaching a screenshot from my browser's console, in case it helps.

Update: #2 issue seems to be related with the editor and it's permissions. So can be regarded resolved

 Kind regards,
Sakis

 
Tuesday, 15 June 2021 10:51 CDT
tampe125

Hello,

regarding the Instant Reply View button: can you please clear the cache and check for browser console errors? We uploaded a lot of javascript files in the latest versions.

Regarding the editor: we moved from the BBcode editor to the HTML one. ATS will use the default one, provided by Joomla. You should double check that the user that is using ATS can actually use the HTML editor on your website.



Davide Tampellini

Developer and Support Staff



Italian: native

English: good



Please keep in mind my timezone and cultural differences when reading my replies. Thank you!



Thursday, 17 June 2021 05:12 CDT
sakis

Hi Davide

regarding the Instant Reply View button: can you please clear the cache and check for browser console errors?
No js error and cache is cleared.

I have the impression that it is a css related issue.

There is a "trace" of a modal at the bottom of the list. See screenshot

Inspecting the css, the only applied styling is coming from the fef.

Your help is really appreciated.

 

Regarding the editor: we moved from the BBcode editor to the HTML one. ATS will use the default one, provided by Joomla. You should double check that the user that is using ATS can actually use the HTML editor on your website.

Is it possible to define an editor that will be used in ATS? I do not want to provide all the editor buttons and functionalities i use to the backend in ATS frontend.

Kind regards,
Sakis

 

 
Thursday, 17 June 2021 08:10 CDT
tampe125

Regarding the modal issue

I suspect there's another plugin injecting its own jQuery version, causing the modal to generate an error. As you can see on our site, the view button is working as expected.

HTML editor

No that's not possible. If you want to hide some buttons, you have to create new groups and assign those buttons to specific users only.



Davide Tampellini

Developer and Support Staff



Italian: native

English: good



Please keep in mind my timezone and cultural differences when reading my replies. Thank you!



Saturday, 17 July 2021 20:17 CDT
system
This ticket has been automatically closed. All tickets which have been inactive for a long time are automatically closed. If you believe that this ticket was closed in error, please contact us.
This ticket is closed, therefore read-only. You can no longer reply to it. If you need to provide more information, please open a new ticket and mention this ticket's number.

Support Information

Working hours: Typically we work Monday to Friday, 9am to 7pm Cyprus timezone (EEST). Support is provided by the same developers writing the software, all of which live in Europe. You can still file tickets, but we cannot respond to them, outside of our working hours.

Support policy: We would like to kindly inform you that when using our support you have already agreed to the Support Policy which is part of our Terms of Service. Thank you for your understanding and for helping us help you!