Download Our Latest Software

Admin Tools

version 2.5.6 Stable

Released on: Friday, 28 June 2013 08:17

Release Notes

General information

If you have a problem after or before installing the component please read our troubleshooting page. These issues are more likely to occur if you try to upgrade this component while you have an older version of another component of ours still installed on your site.

Release highlights

This version of Admin Tools introduces IPv6 support. If you have an IPv6 enabled web server you can use IPv6 addresses and blocks in white- and black-lists. The automatic IP banning will also work correctly with IPv6 IPs as well. Do note that the Geographic Blocking doesn't work with IPv6 as the third party IP to country database we are using is not IPv6 enabled.

On popular request we added the ability to redirect non-SEF URLs, such as index.php?option=com_oldcomponent¶m1=12¶m2=34. You will need to set the "Keep URL Parameters" option to No in the URL redirection editor for these URLs to work. We also improved the URL editor page to make it self-documenting and easier to understand.

PHP 5.3 is now required

This version requires PHP 5.3 or later. The rationale behind this is explained in our statement of mid-February 2013. It won't install on hosts running PHP 5.2 or earlier. Moreover, due to the necessary Joomla! API changes found only in Joomla! 2.5.6 or later, this version will not install on Joomla! 2.5.5 or earlier versions. In any case, it will tell you exactly why it cannot be installed (minimum PHP or Joomla! version not satisfied).

Changelog

New features

  • Allow URL redirections to keep (default) or drop query parameters, useful for redirecting non-SEF URLs
  • IPv6 support

Miscellaneous changes

  • Remove time penalty when blocking auto-banned IPs due to resource usage considerations

Bug fixes

  • [LOW] Pre-installation script would run the wrong SQL files on upgrade (normally not causing a problem, but still it's not the intended behaviour)
  • [LOW] The .htaccess Maker exception you'd add for files and folders with dashes in their names would not be effective
  • [LOW] The .htaccess Maker would assume that Apache version is 2.0 when it's not reported. Many Apache 2.5 servers are configured like that. We now assume version 2.5 in this case.
  • [MEDIUM] Combining CSS and Javascript using the plugin delivery method doesn't work on Joomla! 3.1