Download Our Latest Software

Admin Tools

version 3.0.3 Stable

Released on: Thursday, 17 July 2014 11:21

Release Notes

Release highlights

Removed the CSS and Javascript combination / minification feature. CSS and Javascript combination cannot realistically work with most templates published by major template clubs due to the way their JS/CSS is written. This is something that we cannot fix on our end. Moreover, combination of JS and CSS is not as important as "page optimisation" tools lead you to believe. Unlike four years ago, modern browsers will download up to 8 files in parallel and have become vastly more efficient at parsing CSS and JS, minimising the performance impact of uncombined JS and CSS. Furthermore minification and compression is not advisable to be performed by PHP code as it is very slow. Instead you can have your web server deliver compressed copies of your media files. This can be done with .htaccess and NginX configuration files, something our .htaccess and NginX Configuration Maker features of Admin Tools Professional already support. Should you insist on combining and minifying CSS and Javascript on your site you can use one of the several free extensions in the Site Performance section of the Joomla! Extensions Directory.

Important note regarding Joomla! updates

Admin Tools 2.5.7 and later no longer includes the Joomla! Updater feature and the Joomla! update icon notification plugin. As the core Joomla! Update component and icon notification plugin, written by our team and donated to the Joomla! project, have a very slow release cycle we decided to release an improved Joomla! update component called Akeeba CMS Update. It is available free of charge. It is still considered alpha quality software as we cannot work around Joomla!'s post-installation script which is bound to fail on low-end shared hosts. Unfortunately this is a problem with Joomla! itself and it prevents us from providing a smooth update experience to all of our users. We know what is wrong and how to fix it but that requires changing Joomla! itself. Sorry!

PHP 5.3, 5.4 or 5.5 is required

This version requires PHP 5.3, 5.4 or 5.5. The rationale behind this is explained in our statement of mid-February 2013. It won't install on hosts running PHP 5.2 or earlier. PHP 5.3.4 or later is required, due to show-stopper bugs in earlier versions of PHP 5.3. Moreover, due to the necessary Joomla! API changes found only in Joomla! 2.5.6 or later, this version will not install on Joomla! 2.5.5 or earlier versions. In any case, it will tell you exactly why it cannot be installed (minimum PHP or Joomla! version not satisfied).

Joomla! 2.5, 3.2, 3.3 are supported

This version of our software can be installed on Joomla! 2.5.6 or any later 2.5.x release, as well as any 3.2.x or 3.3.x release. It is not compatible with Joomla! 3.0 or 3.1. These versions of Joomla! are old and vulnerable. If you are using them please upgrade to the latest Joomla! 3 release available from Joomla.org.

Changelog

Bug fixes

  • [LOW] Templates without a .sys.ini file show their default installed style as JLIB_INSTALLER_DEFAULT_STYLE

Removed features

  • Removed the CSS and Javascript combination / minification feature as it's technically impossible to make as reliable as we'd like it to be