Download Our Latest Software

Admin Tools

version 3.4.3 Stable

Released on: Sunday, 11 January 2015 08:14

Release Notes

PHP 5.3.4 or later is required

This version requires PHP 5.3.4 or later, due to show-stopper bugs in earlier versions of PHP 5.3. Important note on reading PHP versions: PHP 5.3.20 is newer than 5.3.10 which is newer than 5.3.4. Moreover, PHP 5.4.0 is newer than PHP 5.3.4. Joomla! 3.3 and later already requires PHP 5.3.10 or later. Also keep in mind that the entire PHP 5.3 series is end of life since August 2014 and MUST NOT be used on live sites any more for performance and security reasons.

VERY IMPORTANT: Using Joomla! 3.2 on PHP 5.6 or later is NOT supported. Joomla! 3.2 was not designed to run on this PHP version and executes erratically, with numerous functional issues. If you use our software on this combination of Joomla! and PHP versions we cannot and will not provide any support.

Compatibility with Joomla! versions

This release requires one of the following Joomla! versions:

  • 2.5.6 or any newer version in the 2.5.x family
  • 3.2.1 or any newer version in the 3.2.x family
  • Any version in the 3.3.x or 3.4.x family

Due to the necessary Joomla! API changes found only in Joomla! 2.5.6 or later, this version will not install on Joomla! 2.5.5 or earlier versions. In any case, if your server doesn't meet the minimum requirements it will tell you exactly why it cannot be installed (minimum PHP or Joomla! version not satisfied).

Reading Joomla! versions: Joomla! 2.5.20 is newer than 2.5.10 which is newer than 2.5.6. Moreover, Joomla! 3.4.0 is newer than 3.3.6 which is newer than 2.5.28. In other words, you need to separately compare each one of the the three numbers separated by dots. These numbers are NOT decimals and trailing zeroes DO matter, i.e. 1.10 (pronounced "one dot ten", not one dot one oh) is larger than 1.2.

Last release branch with Joomla! 2.5 and 3.2 support

Admin Tools 3.4.x is the last release branch of Admin Tools to support the end-of-life Joomla! 2.5 and 3.2 families. Starting with Admin Tools 3.5.0 we will stop supporting Joomla! 2.5 and 3.2. If you're on Joomla! 3.2 you can upgrade to Joomla! 3.3/3.4 any time, as long as you have a PHP version released in the last four and a half years (5.3.10 or later). If you are on Joomla! 2.5 you can read our Joomla! 2.5 end of life announcement for details and useful information regarding your site's migration to Joomla! 3.

Changelog

Bug fixes

  • [LOW] The obsolete pro.php / core.php files of the system plugin were not removed automatically

Critical bugs and important changes

  • Work around BROKEN Apache installations when you are using BOTH .htaccess files (.htaccess Maker OR Joomla! htaccess.txt contents) AND administrator password protection. If you were affected by this issue PLEASE ASK YOUR HOST TO FIX THEIR SERVERS per the release notes of this version!

Release Files

Documentation (PDF)

admin-tools.pdf.zip

PDF

Download now

Admin Tools Core

com_admintools-3.4.3-core.zip

PHP 5.3 PHP 5.4 PHP 5.5 PHP 5.6 Joomla! 2.5 Joomla! 3.2 Joomla! 3.3 Joomla! 3.4

Download now