Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.
Latest post by nicholas on Sunday, 27 September 2026 12:43 CDT
You said that your hosting solution adds this to the virtual host configuration:
Alias /error/ "/var/www/example.com/web/error/"
ErrorDocument 400 /error/400.html
ErrorDocument 401 /error/401.html
ErrorDocument 403 /error/403.html
ErrorDocument 404 /error/404.html
ErrorDocument 405 /error/405.html
ErrorDocument 500 /error/500.html
ErrorDocument 502 /error/502.html
ErrorDocument 503 /error/503.html
You have not told me if the /var/www/example.com/web/error directory actually exists, if it's readable by Apache, whether it has the custom error page files, and whether they are readable.
You can PROBABLY solve this by adding error to the "Allow direct access, except .php files, to these directories" option.
Ideally, you should just add the following to "Custom .htaccess rules at the bottom of the file" to reset custom error pages since it does not seem you are serving concrete custom error pages anyway:
ErrorDocument 400 default
ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 405 default
ErrorDocument 500 default
ErrorDocument 502 default
ErrorDocument 503 default
Nicholas K. Dionysopoulos
Lead Developer and Director
🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!
The redirect flags are not important in this case. Grab a cold drink, this is convoluted. Having an Alias for the error pages complicates things. The documentation says this:
First, all Redirects are processed before Aliases are processed, and therefore a request that matches a Redirect or RedirectMatch will never have Aliases applied. Second, the Aliases and Redirects are processed in the order they appear in the configuration files, with the first match taking precedence.
Since the protection is a set of redirect rules you'd have to set your Alias rules again in the bottom of the file for them to apply. You cannot have the server protection (redirect rules) in .htaccess and fall back to the Alias rules from your VirtualHost. I get what they are doing and why they are doing it. There is no good way to do it when you can override the Apache server configuration in so many ways: default config, virtual hosts, directory rules, cascading .htaccess, and I am pretty sure I forgot something...
That said, I've found that most people don't actually use custom error pages and when they do they are materially worse than the built-in ones. This sounds odd, but – depending on the browser – if the server response body for an HTTP status other than 200 is less than around 200 bytes the browser shows its own error page which is more user-friendly as it has browser-specific information on what the user can do next. Moreover, having custom error pages for 404 and 403 errors may replace Joomla's built-in error pages which is a lot more confusing.
And that's why I suggested using the ErrorDocument ... default lines. Falling back to the default Apache error pages allows the browser to display its own error page when appropriate, and allows Joomla to handle its 403, 404, and 500 errors with site-specific content.
Nicholas K. Dionysopoulos
Lead Developer and Director
🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!
Working hours: We are open Monday to Friday, 9am to 7pm Cyprus timezone (EET / EEST). Support is provided by the same developers writing the software, all of which live in Europe. You can still file tickets outside of our working hours, but we cannot respond to them until we're back at the office.
Support policy: We would like to kindly inform you that when using our support you have already agreed to the Support Policy which is part of our Terms of Service. Thank you for your understanding and for helping us help you!