Support

Akeeba Backup for Joomla!

#12349 Problem with auto update

Posted in ‘Akeeba Backup for Joomla!’
This is a public ticket

Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.

Environment Information

Joomla! version
n/a
PHP version
n/a
Akeeba Backup version
n/a

Hertak
Mandatory information about my setup:

Have I read the related troubleshooter articles above before posting (which pages?)? Yes
Have I searched the tickets before posting? Yes
Have I read the documentation before posting (which pages?)? Yes
Joomla! version: (2.5.4)
PHP version: (5.3.9)
MySQL version: (5.0.95-community-log)
Host: (Vps that i control)
Akeeba Backup version: (3.5)

EXTREMELY IMPORTANT: Please attach a ZIP file containing your Akeeba Backup log file in order for us to help you with any backup or restoration issue. If the file is over 2Mb, please upload it on your server and post a link to it.

Description of my issue: I have several sites on several servers recently i buy a pro version on all server i have no problem with the update feature but when i update to pro version (3.4.3) i loose all the update feature in all server i can update the free version but not the pro version. The message say´s i have to add http://www.akeebabackup.com/updates/abprosvn.ini to the firewall exclusion, i have a vps i made this but don´t work.
Thing´s i made:
Install free version ----> Autoupdate works
Install pro version ----> Autoupdate don´t work
Add direction to firewall----> Don´t work
Turn off the firewall ----> Don´t work
Uninstall the pro version and install the free ----> Work the autoupdate
Reeinstall pro version ----> Don´t works
Change the id for a fake id to test the number but the error is other the id code is correct.
This is on three different servers curl is on fopen is on i don´t know what happens.
I can manually update the component but the autopdate is a good feature to keep. Thanks.

nicholas
Akeeba Staff
Manager
After manually updating you should be able to click on the "Live Update Not Supported" button in your Akeeba Backup control panel. Then you should be able to click on the Refresh Update Information and that should reset the Live Update status. If that doesn't work, please wait for 24 hours and retry that.

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

Hertak
Sorry i forget i did the refresh information and don´t work. Now i try again and have the same message. I think is very rare this are three different servers 2 are on a resseler account and 1 on a vps. The vps i control is there something that i can do on the vps? Thanks.

nicholas
Akeeba Staff
Manager
It might just be stuck information in the update cache (which is stored in the _extensions table of your site along with configuration information). Let's try this. Try uninstalling and reinstalling Akeeba Backup on one of the sites. Please note that this will cause Akeeba Backup to lose all of its settings and your backups stored in administrator/components/com_akeeba/backup are also going to be removed. Does that fix the issue?

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

Hertak
Thanks that works but have some details.
First i uninstall akeebabackup then install version 3.4.3 i put the download id and the autoupdate say is a new version. try to autoupdate and have a message say´s something like "Problem to update you need to update manually" (I have Spanish language installed the message was in spanish) i click on refresh info from the server and try again and receive a blank page, a little mad i push f5 key and magic akeeba update without a problem. On the second and the third server all was perfect.
Thanks a lot.

nicholas
Akeeba Staff
Manager
It seems that the communication to the update server is very slow, that's what was triggering the blank page and the "not supported" message. Well, if you get the "not supported" message again you know what you have to do. I'm glad it's all working now!

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

Hertak
Thanks all works perfect.

Support Information

Working hours: Typically we work Monday to Friday, 9am to 7pm Cyprus timezone (EEST). Support is provided by the same developers writing the software, all of which live in Europe. You can still file tickets, but we cannot respond to them, outside of our working hours.

Support policy: We would like to kindly inform you that when using our support you have already agreed to the Support Policy which is part of our Terms of Service. Thank you for your understanding and for helping us help you!