Support

Akeeba Backup for Joomla!

#35994 Akeeba Backup Pro not saving changes to config

Posted in ‘Akeeba Backup for Joomla!’
This is a public ticket

Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.

Environment Information

Joomla! version
n/a
PHP version
n/a
Akeeba Backup version
n/a

traveller_inc

Please look at the bottom of this page (under Support Policy Summary) for our support policy summary, containing important information regarding our working hours and our support policy. Thank you!


EXTREMELY IMPORTANT: Please attach a ZIP file containing your Akeeba Backup log file in order for us to help you with any backup or restoration issue. If the file is over 2Mb, please upload it on your server and post a link to it.


Description of my issue: The backup configuration does not seem to be saving. Also the Wizard keeps popping up asking to configure itself, which I have already performed.    A little background info: I just upgraded to AB 8.0.11 from 8.0.6.  Had some trouble during the upgrade with FOF being a newer version. FOF4 is installed. I uninstalled AB Pro 8.0.6 and manually installed 8.0.11 Pro via the upload file option. That seemed to work around the FOF error (at least it said install success). Now that I'm trying to configure/tune the backup configuration after running the wizard, it doesn't save my changes to options like "Output directory", "Site root override",  or "Force Site Root".  However, it did save my change to "Profile Description".  I read the instructions to include the Akeeba Backup Log file, but one does seem to exist or it is empty. When going to Troubleshooting section of AB and clicking on "view log" I get "No log file was found". I must have done something wrong, but not able to figure it out. Thank you for any light you can shed on my issue.

Thank you,

Chris

 

nicholas
Akeeba Staff
Manager

This sounds like a JavaScript issue. I know that from the outside it sounds like a weird conclusion. Let me tell you how the Configuration form works. The top part of the form with the profile description and the option for One Click backups is a regular HTML form. The rest of the Configuration page is rendered by JavaScript. These fields are prepared by JavaScript. If the JS is broken or an old version's JS is being loaded you will get various problems, from the Configuration page not appearing to its data not being saved.

First, try clearing your browser's cache.

If this didn't help, think whether your site is behind a CDN (like CloudFlare) or a caching proxy. It's possible the JavaScript is cached there; you will need to reset those caches to and then clear your browser's cache yet again.

If nothing so far helped export your backup profiles, keep a copy of your backups (if you have any in the default backup output directory), uninstall Akeeba Backup, reinstall it and import your backup profiles.

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

System Task
system
This ticket has been automatically closed. All tickets which have been inactive for a long time are automatically closed. If you believe that this ticket was closed in error, please contact us.

Support Information

Working hours: Typically we work Monday to Friday, 9am to 7pm Cyprus timezone (EEST). Support is provided by the same developers writing the software, all of which live in Europe. You can still file tickets, but we cannot respond to them, outside of our working hours.

Support policy: We would like to kindly inform you that when using our support you have already agreed to the Support Policy which is part of our Terms of Service. Thank you for your understanding and for helping us help you!

Summer vacations: Our support will be closed for replies and new tickets from August 6th to August 21st, 2022 due to summer vacations.