Support

Akeeba Backup for Joomla!

#36642 fof 4.1.2 cannot be installed

Posted in ‘Akeeba Backup for Joomla!’
This is a public ticket

Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.

Environment Information

Joomla! version
n/a
PHP version
n/a
Akeeba Backup version
n/a

deltapapa

Hi, when I want to update my Joomla 4.1 installation from fof 4.1.1 to 4.1.2, I get the following error message:
Warning - You need Joomla! 4.0.999 or earlier to install this package but you have 4.1.0 installed

However, Joomla 4.1.0 is installed. 

I have another site where I installed PHP 8.1 and Joomla 4.1.0, the update from fof went through without any problems.

WBR,

deltapapa

nicholas
Akeeba Staff
Manager
 

Please note that we have Joomla 4 native versions of all of our extensions. The Joomla 4 native extensions DO NOT use FOF and FEF.

As we announced back in August 2021, FOF and FEF are deprecated and will be discontinued on August 17th, 2023 when Joomla 3.10 becomes End of Life.

Legacy versions of our software for Joomla 3 are no longer developed beyond the point of security fixes and PHP version compatibility fixes. There are no new features.

The current versions of FOF and FEF are considered legacy with no intent to replace them. As noted, we no longer use these libraries. You can uninstall them if you are using Joomla 4 and the newest, Joomla 4 native versions of our extensions.

Legacy (Joomla 3 compatible) versions of our software are currently supported on Joomla 4.1 only as an “upgrade bridge”; they cannot be installed directly on Joomla 4.1. If you had already installed them on a Joomla 3.10 or 4.0 site before upgrading to Joomla 4.1 they will not break your site. This makes Joomla upgrades possible. You are supposed to install the new versions of our software on your upgraded site and remove the no longer needed FOF and FEF libraries.

Starting with the release of Joomla 4.1 we will only support the legacy versions of our extensions for a. use on Joomla 3.10 and b. for upgrading from Joomla 3.10 to the latest version of Joomla 4.x. We will not support the use case where our legacy extensions are still installed on a Joomla 4 site being upgraded to a new Joomla 4 version. There was a period of six months were people could've upgraded from Joomla 3 to 4 and upgraded our extensions to their new versions. There is no longer a reason for us to support legacy extensions for use in new versions of Joomla.

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

deltapapa

Hello Nicholas,
Thank you very much for the very detailed explanation.
This is actually a migration from a Joomla 3.10 to 4.0 and then updated to 4.1.
The other side, where I thought the update went through, was a fresh 4.0, there are no more fof and fef there, I was mistaken.
I ran your akeeba/magiceraser over it before the migration, and was wrongly thinking that all outdated frameworks would be deleted with it.
Okay, very good, I'll delete the old fef and fof extensions, that fixes the update problem.
One more question: I still have a library in my Joomla, "FOF-Site-2.4.3-2015-04-22", which I can safely delete, right?
I use the latest extensions from you, so that should actually be superfluous.

Thank you for your quick help as always :-)
Best Regards,
deltapapa

nicholas
Akeeba Staff
Manager

> One more question: I still have a library in my Joomla, "FOF-Site-2.4.3-2015-04-22", which I can safely delete, right?

Yes. That's an ancient version of FOF which we stopped developing in 2015 and discontinued in 2016. This was included in Joomla 3 as part of the Joomla 3 package. You don't need. You can remove it.

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

System Task
system
This ticket has been automatically closed. All tickets which have been inactive for a long time are automatically closed. If you believe that this ticket was closed in error, please contact us.

Support Information

Working hours: Typically we work Monday to Friday, 9am to 7pm Cyprus timezone (EEST). Support is provided by the same developers writing the software, all of which live in Europe. You can still file tickets, but we cannot respond to them, outside of our working hours.

Support policy: We would like to kindly inform you that when using our support you have already agreed to the Support Policy which is part of our Terms of Service. Thank you for your understanding and for helping us help you!

Summer vacations: Our support will be closed for replies and new tickets from August 6th to August 21st, 2022 due to summer vacations.