Support

Akeeba Backup for Joomla!

#36732 Picking up Back Core. Not pro

Posted in ‘Akeeba Backup for Joomla!’
This is a public ticket

Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.

Environment Information

Joomla! version
n/a
PHP version
n/a
Akeeba Backup version
n/a

hotrod007

  I have 1 of my 68 sites.. that all run the pro version.. but the site is calling for the Core Update.. and I have to manually upload the pro version every time..

hotrod007

hotrod007

  Title should read...  Site is picking up Akeeba Core to upgrade.. when it's running Akeeba Pro...

nicholas
Akeeba Staff
Manager

There is no such thing as a "latest" version, especially since August 17th, 2021 until at least August 17th, 2023 where we have two major versions of Joomla (3 and 4) releasing "latest" versions and two version branches of each of our software for each corresponding Joomla version.

Right now there are two "latest" versions of Joomla (3.10.6 and 4.1.0) and two "latest" versions of Akeeba Backup (8.1.2 and 9.2.0). 

Your ticket says you are using the "latest" versions. I can read it many different ways:

  • Joomla 3 up to and including 3.10.5 with Akeeba Backup up to and including 8.1.1. Not supported, upgrade Joomla and Akeeba Backup.
  • Joomla 3 up to and including 3.10.5 with Akeeba Backup 9.0.0 or later. Not supported, cannot be installed.
  • Joomla 3.10.6 with Akeeba Backup 9.2.0. Not supported, cannot even be installed.
  • Joomla 3.10.6 with Akeeba Backup 8.1.2. Currently "latest" supported combination 1.
  • Joomla 4.0 alpha, beta or release candidate. Not supported.
  • Joomla 4.0 (any stable version) with Akeeba Backup lower than 9.2.0. Not supported, upgrade Joomla and Akeeba Backup.
  • Joomla 4.1.0 with Akeeba Backup 8.1.2. Not supported, upgrade to Akeeba Backup 9.2.0.
  • Joomla 4.1.0 with Akeeba backup 9.2.0. Currently "latest" supported combination 2.

With the currently supported combinations 1 and 2 Joomla cannot find an update. Since your problem is about Joomla finding the "wrong" update you are most definitely not running anything even close to a "latest" version, possibly of either Joomla or Akeeba Backup.

Moreover, as you can read in the documentation, this problem is a Joomla bug; the extensions update code is part of Joomla itself, we have no control over it.

If you would like us to help you find a workaround please file a new ticket putting more effort into providing the exact version numbers. We need them, otherwise we wouldn't be asking for them.

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

Support Information

Working hours: Typically we work Monday to Friday, 9am to 7pm Cyprus timezone (EEST). Support is provided by the same developers writing the software, all of which live in Europe. You can still file tickets, but we cannot respond to them, outside of our working hours.

Support policy: We would like to kindly inform you that when using our support you have already agreed to the Support Policy which is part of our Terms of Service. Thank you for your understanding and for helping us help you!

Summer vacations: Our support will be closed for replies and new tickets from August 6th to August 21st, 2022 due to summer vacations.