Support

Akeeba Backup for Joomla!

#8486 Error: No database definitions were found or no database was selected

Posted in ‘Akeeba Backup for Joomla!’
This is a public ticket

Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.

Environment Information

Joomla! version
n/a
PHP version
n/a
Akeeba Backup version
n/a

user11512
Hello,

I've been using JoomlaPack for a while now and it has always worked great for me. I just recently upgraded to Akeeba Pro, I'm running 3.0 Stable. I have setup cron jobs to backup twice each day. I have been using a sub-domain as a development area for several months now and I am finally ready to push the site live to the root domain.

I created a new database for the live site to use, and I am indicating this to ABI in step 2 (DB Restore). But every time I try to move my site to the root domain, I get the error: "No database definitions were found or no database was selected."

I have tried over 10 different backup files and each one fails at step 2. I am using BlueHost, and my development site is backing up directly to my server. I am then copying the backup file to new location using CPanel File Manager.

When Akeeba is performing a backup, the step "Finalizing the backup process" takes an unusually long time. The "Last server response" message hits 110 seconds before it refreshes a few times and finalizes the backup. Akeeba confirms that the backup is complete, but this seems like a very long time for a server response.

I am not sure what else I can try to get this fixed. Any help would be greatly appreciated.

dlb
The error message indicates that the /installation/sql/databases.ini file is not present or can't be read. If that file is there, it may be a permissions error. Flag the /installation folder, sub-folders and files 777. (Some servers will throw a 500 error on files flagged 777, back it down to 755 if you get a 500 error.) There is usually a flag in your ftp client to apply permission changes to the entire tree instead of just the current folder.


Dale L. Brackin
Support Specialist


us.gifEnglish: native


Please keep in mind my timezone and cultural differences when reading my replies. Thank you!


????
My time zone is EST (UTC -5) (click here to see my current time in Philadelphia, PA)

user11512
I got this working. The databases.ini file was there, but ABI wasn't updating that file with the new database information I was feeding it in the GUI.

So I manually edited the databases.ini file so that it contained my new database name, user and password. Once that was done, it installed just fine.

Another issue that cropped up: I tried backing up as a ZIP file and it kept stalling out. Not sure if anyone else is experiencing that issue, but it might be something to look into.

Thanks for the help!

dlb
I didn't think the installer updated databases.ini. That should hold the default login details for the databases. The Joomla! database information is updated in the configuration.php file, any other databases wouldn't be written anywhere. Oh, well. I'm glad you got it working.

The zip file format is much slower than the jpa format. This is due to the calculation of the internal CRC32 checksums that the zip format needs. The time difference isn't much on a human level, but it is significant on a computer level.


Dale L. Brackin
Support Specialist


us.gifEnglish: native


Please keep in mind my timezone and cultural differences when reading my replies. Thank you!


????
My time zone is EST (UTC -5) (click here to see my current time in Philadelphia, PA)

Support Information

Working hours: Typically we work Monday to Friday, 9am to 7pm Cyprus timezone (EEST). Support is provided by the same developers writing the software, all of which live in Europe. You can still file tickets, but we cannot respond to them, outside of our working hours.

Support policy: We would like to kindly inform you that when using our support you have already agreed to the Support Policy which is part of our Terms of Service. Thank you for your understanding and for helping us help you!

Summer vacations: Our support will be closed for replies and new tickets from August 6th to August 21st, 2022 due to summer vacations.