Support

Akeeba Backup for WordPress

#28185 Lost postprocessing settings

Posted in ‘Akeeba Backup for WordPress’
This is a public ticket

Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.

Environment Information

WordPress version
n/a
PHP version
n/a
Akeeba Backup version
n/a

zebrafilm
Since the last updates we lost all PostProcessing opties in our clients backup settings.
This happened only on the WP version, not the Joomla or Solo version.

The postprocessing is suddenly set to 'none' while it was on Amazon S3

We see this on Linux and Windows hosting and is common on all installs.

This ticket can be closed but it seems wise to mention this.

(and congrats with the new design)

nicholas
Akeeba Staff
Manager
Do you still see the post-processing options? If not, you have accidentally installed the Core version on top of the Professional. Install the Professional version on top to fix that.

If you still see the post-processing options, has any other option been modified (other than file, folder and database filters)? If it has, something changed in the cryptography setup. This can mean that either the server key file was accidentally deleted (e.g. the host deleted it without a warning because they mistook the base64 encoded cryptographic key for malicious content - it wouldn't be the first time) or something changed in the server configuration which affected cryptography. In this case setting up the backups is, unfortunately, the only option.

Please note that since several months ago -almost a year now- we have switched from using the obsolete PHP mcrypt module to the PHP OpenSSL module for handling cryptography. This shouldn't be a problem unless you have a server whose PHP OpenSSL module is compiled against an ancient OpenSSL library that doesn't properly support AES-128.x Again, in this case your only option is to set up the backup again.

Finally let me note that the settings storage is part of Akeeba Engine, the backup engine which is common across all of our backup products (Solo, Backup for Joomla! and Backup for WordPress). On top of that, Backup for WordPress and Solo are actually the same application with a different GUI wrapper (WordPress plugin vs none) and a different Platform component (integration with the lower level system, WordPress vs direct PHP). It doesn't make sense that encryption works on two but on the third. If I were to guess I'd think that the WordPress sites are on a different server setup than the rest of your sites (Joomla! and those backed up by Solo).

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

System Task
system
This ticket has been automatically closed. All tickets which have been inactive for a long time are automatically closed. If you believe that this ticket was closed in error, please contact us.

Support Information

Working hours: Typically we work Monday to Friday, 9am to 7pm Cyprus timezone (EEST). Support is provided by the same developers writing the software, all of which live in Europe. You can still file tickets, but we cannot respond to them, outside of our working hours.

Support policy: We would like to kindly inform you that when using our support you have already agreed to the Support Policy which is part of our Terms of Service. Thank you for your understanding and for helping us help you!

Summer vacations: Our support will be closed for replies and new tickets from August 6th to August 21st, 2022 due to summer vacations.