Support

Akeeba Solo

#28595 Transfer Wizard - no action, and no error message

Posted in ‘Akeeba Solo (standalone)’
This is a public ticket

Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.

Environment Information

PHP version
n/a
Akeeba Solo version
n/a

vbandke
Hi Nicholas,

I have been using Akeeba Backup pro on my Joomla sites for many years now, with no issues whatsoever. Thus, when a friend asked me to help administer his web site, which runs among other phpbb3, I of course suggested to use Akeeba Solo for the backup process.

I downloaded Akeeba Solo Core for testing things, and ran into a few snags, which I will report in different tickets.

The good news first:The installation worked fine, and I am able to make backups.

I have disabled that Ad Blocker in my browser.


When I try to use the „Transfer Wizard“ and enter the site URL, a form opens where I can enter ftp and/or other info. Regardless which file transfer method I choose and then fill in the data, nothing happens when I Klick the „proceed with restoration“ button, no action, no error message, nothing.


I noticed that on this page there is no „Donate“ banner or something similar, as opposed to the other pages

Yes, I read the docs (if every thing else fails, I always do), but I must be missing something ...


Is this a limitation of the Core/Test Version, and should I try the Pro Version. (Which I would subscribe to anyhow when the issues have been worked out)


With best regards

Volker

vbandke
Akeeba Solo Core Version: 2.4.0
Php Version: 7.1

Also tried on different servers with PHP Version 5.6.1

Also tried on different Browsers, including Safari on iPad, and Firefox, Edge, IE on PC with Win 10 Professional

With best regards


Volker

tampe125
Akeeba Staff
Hello,

It looks like you are experiencing a Javascript issue.
In order to provide support for your problem we need to know the exact Javascript error that is thrown. For this reason we would like to ask your to please attach a screenshot of the Javascript console of your browser, taken immediately after triggering the issue you want us to help you with.

Here you can find a friendly reminder on how to open the Javascript console:
  • Chrome Press either CTRL + SHIFT + J (ALT + CMD + J under Mac) to open the "Console" tab of the Developer Tools.
  • Safari Press CTRL + ALT + I (ALT + CMD + C under Mac) to open the Web Inspector. Note: This works only if the "Show Develop menu in menu bar" check box in the Advanced tab of the Preferences menu is checked!
  • Firefox Press CTRL + SHIFT + K (ALT + CMD + K under Mac) then click on the "Console" tab


Please note that we need a screenshot, not a paste of the log text. We have determined that, in most cases, pasting the log text alters the sequence of the function calls, becoming useless for debugging purposes.

Thank you in advance for helping us help you!

Davide Tampellini

Developer and Support Staff

🇮🇹Italian: native 🇬🇧English: good • 🕐 My time zone is Europe / Rome (UTC +1)
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

vbandke
Hello Davide,

Thanks for your reply. I have activated the Javascript console before invoking the Transfer Wizard "Check" function. See screen capture "ScreenHunter_262.png


Clicking onto CHECK and then filling in the forn and finally pressing "Proceed to restoration" does not change anything in the JS-Console, as can be seen "Screenhunter_265.png"

I have expanded the "TypeError" entry in the console screen for your convenience (ScreenHunter_266.png)


With best regards


Volker

tampe125
Akeeba Staff
Ok, I got where's the glitch.
Can you please install the latest dev release and try again? That should fix the problem

Davide Tampellini

Developer and Support Staff

🇮🇹Italian: native 🇬🇧English: good • 🕐 My time zone is Europe / Rome (UTC +1)
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

vbandke
Thanks, Davide,


I have downloaded and installed the Snapshot into the development environment, and it fixes this issue, and a similar issue where I could not import a profile (no action on clicking the import button, either.

Now, when will the fix be incorporated in the Akeeba Solo Pro Version? While I don‘t mind having it in the Test system I am not comfortable in putting a developers snapshot into the Staging or the Production system.


With best regards, any many thanks for you help


Volker

tampe125
Akeeba Staff
Usually a new version is released every 2-3 weeks, so in a month maximum you should have a new version with the fix.

Davide Tampellini

Developer and Support Staff

🇮🇹Italian: native 🇬🇧English: good • 🕐 My time zone is Europe / Rome (UTC +1)
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

vbandke
Molto bene!

You may close this ticket now


With best regards


Volker

Support Information

Working hours: Typically we work Monday to Friday, 9am to 7pm Cyprus timezone (EEST). Support is provided by the same developers writing the software, all of which live in Europe. You can still file tickets, but we cannot respond to them, outside of our working hours.

Support policy: We would like to kindly inform you that when using our support you have already agreed to the Support Policy which is part of our Terms of Service. Thank you for your understanding and for helping us help you!

Summer vacations: Our support will be closed for replies and new tickets from August 6th to August 21st, 2022 due to summer vacations.