Support

Akeeba Solo

#30081 SQLite and profile

Posted in ‘Akeeba Solo (standalone)’
This is a public ticket

Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.

Environment Information

PHP version
n/a
Akeeba Solo version
n/a

rkonik
I bought a Pro version and started tests.

I was very interested in installing using SQLite. The installation went smoothly and performed tasks according to what I wanted.

The problem appeared when I wanted to add another profile.
The default is No. 1. As I added the profile, it got ID 0.
When adding another, an error pops up. This problem does not occur with other Databases.

tampe125
Akeeba Staff
Hello,

it seems that the problem comes from SQLite database not being able to correctly handle the "zero" value in the same way MySQL is doing.
We're going to investigate it, in the meanwhile you should fallback to using the MySQL installation.

Davide Tampellini

Developer and Support Staff

🇮🇹Italian: native 🇬🇧English: good • 🕐 My time zone is Europe / Rome (UTC +1)
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

System Task
system
This ticket has been automatically closed. All tickets which have been inactive for a long time are automatically closed. If you believe that this ticket was closed in error, please contact us.

Support Information

Working hours: Typically we work Monday to Friday, 9am to 7pm Cyprus timezone (EEST). Support is provided by the same developers writing the software, all of which live in Europe. You can still file tickets, but we cannot respond to them, outside of our working hours.

Support policy: We would like to kindly inform you that when using our support you have already agreed to the Support Policy which is part of our Terms of Service. Thank you for your understanding and for helping us help you!

Summer vacations: Our support will be closed for replies and new tickets from August 6th to August 21st, 2022 due to summer vacations.