You cannot do that, and there's no plan to implement this. There's a very good reason. Search engines follow redirections. A ticket issuing an HTTP 302 redirection to a page returning a regular HTTP 200 OK response results in that content being indexed as the ticket's content. Since you'll have many of those tickets leading to the same page it is understood as duplicate content and your site disappears off the face of search engines.
On top of that, a redirection to an HTTP 200 OK page when access is denied is semantically wrong. The correct response as per the RFCs is HTTP 403 Access Denied. Beyond search engines, caching proxies, CDNs, and everything that is standards-compliant will be caching the redirected content as the page's canonical content. You will end up in a situation where the user logs in, has access, tries to visit the ticket, still sees the message they need to do XYZ to get access. Frustrated user, bad times all around.
What you can and should do is customize your site template's error page to show any necessary information. How to do that depends entirely on your template. I write my own templates either from scratch or by customizing the built-in Cassiopeia template; I can't tell you how to do it on your site.
Nicholas K. Dionysopoulos
Lead Developer and Director
🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!