Support

UNiTE, Remote CLI, eXtract Wizard

#24770 I cannot find a way to connect to your remote site.

Posted in ‘UNiTE and Remote CLI’
This is a public ticket

Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.

Environment Information

PHP version
n/a
Tool
UNiTE
Tool version
n/a

user63792
 Hello, I used "United Akeeba" to transfer periodically with a cronjob a site mydominio.com to stage.mydominio.com. These two domains were allocated on the same server and everything worked perfectly.

Now, I would like to transfer,with a cronjo, the mydominio.com to x.y.w.z site another server, but this is not possible and is written in the log file:



20160323 | 17: 05: 01 | Scanning inbox for XML files ...

20160323 | 17: 05: 01 | Parsing inbox / misterfesta.com-sptosg.xml

20160323 | 17: 05: 01 | ### Starting Job # 0 ###

20160323 | 17: 05: 01 | Running validator

20160323 | 17: 05: 01 | Sorry, I can not find a way to connect to your remote site.

20160323 | 17: 05: 01 | 0 ### ### Finished job #

20160323 | 17: 05: 01 | ========================================== =====================================

20160323 | 17: 05: 01 | UNITE finished its run cycle

20160323 | 17: 05: 01 | Total found definitions: 1

20160323 | 17: 05: 01 | Total definitions executed successfuly: 0

20160323 | 17: 05: 01 | Total definitions failed to run: 1


and it is not created even backup (Akeeba Backup) on the source site.
The FTP credentials entered in the xml file are correct. What am I doing wrong?

nicholas
Akeeba Staff
Manager
Please make sure that the remote backup feature is enabled on the remote site and that you're using a secure enough secret word. We recommend using a 64 character long random string consisting of letters a-z, A-Z and numbers 0-9. Also make sure that the secret word is correctly entered in UNiTE.

If this doesn't help you have a firewall issue. Either the server where UNiTE is running doesn't allow outbound connections or the server where your source site is running isn't allowing inbound connections from UNiTE. If both sites are running on the same server it's very likely that the host has a firewall rule which disallows loopback connections, i.e. you can't have a script on the server hit the same or another site on the same server over the web. This is quite common in shared hosts to prevent a hacked site launching an attack against other sites on the same server.

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

user63792
Problem solved, thanks. The FTP connection string was wrong.

Support Information

Working hours: Typically we work Monday to Friday, 9am to 7pm Cyprus timezone (EEST). Support is provided by the same developers writing the software, all of which live in Europe. You can still file tickets, but we cannot respond to them, outside of our working hours.

Support policy: We would like to kindly inform you that when using our support you have already agreed to the Support Policy which is part of our Terms of Service. Thank you for your understanding and for helping us help you!

Summer vacations: Our support will be closed for replies and new tickets from August 6th to August 21st, 2022 due to summer vacations.