Support

UNiTE, Remote CLI, eXtract Wizard

#28297 Extract wizard zip for linux contains only exe and dll files

Posted in ‘UNiTE and Remote CLI’
This is a public ticket

Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.

Environment Information

PHP version
n/a
Tool
UNiTE
Tool version
n/a

Portinfo
When I try to download from this page either
  • extract-cli-macos-linux-4.0.2.zip or
  • extract-wizard-linux-4.0.2.zip


The zip files only contain dll and exe files.
Not sure how to run these on linux or macos.
Can you help?

nicholas
Akeeba Staff
Manager
Please read the download page text. Akeeba Portable Tools will run on any Windows, Linux or macOS computer on which you can run .NET Framework 4.5 or later; or Mono Framework 4.5 or later. On Linux and macOS you will need to install the Mono framework 4.5 or later. In case your Linux distributions offers separate package for Mono Framework and Gtk# please remember to install both. Read the link above for more information on how to download / install it from.

Also see Guide:Running Mono Applications from Mono's documentation.

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

Portinfo
Thanks for that. Presumably thats also why the MacOS extract wizard app is not working either?

It might be helpful to have a readme in the zip files saying simply that

nicholas
Akeeba Staff
Manager
The macOS version, as noted in the download page and my reply above, also needs the Mono framework.

It's worth noting that the same information is also included in the documentation wiki. The documentation wiki is linked to by the download page's text and is available as a link tab at the top of every page of the GitHub repository. The wiki only has three pages. All three pages tell you to install Mono.

Kindly note that you do have to go through the download page to, well, download the software. You (subconsciously) ignored the bold, big type "Requirements" header. The problem does not lie in the lack of information but how our brains have evolved to work. Your brain chooses the syllogistic shortcut "EXE = Windows; I am on Linux; Obviously a bug; File ticket" despite the abundance of information to the contrary already in front of you. Adding a README wouldn't remove that bias. You'd still file this ticket.

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

Support Information

Working hours: Typically we work Monday to Friday, 9am to 7pm Cyprus timezone (EEST). Support is provided by the same developers writing the software, all of which live in Europe. You can still file tickets, but we cannot respond to them, outside of our working hours.

Support policy: We would like to kindly inform you that when using our support you have already agreed to the Support Policy which is part of our Terms of Service. Thank you for your understanding and for helping us help you!

Summer vacations: Our support will be closed for replies and new tickets from August 6th to August 21st, 2022 due to summer vacations.