Support

Site Restoration

#13106 Problem with templates on restored site

Posted in ‘Site restoration’
This is a public ticket

Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.

Environment Information

PHP version
n/a
CMS Type
Other
CMS Version
n/a
Backup Tool Version
n/a
Kickstart version
n/a

user66965
Mandatory information about my setup:

Have I read the related troubleshooter articles above before posting (which pages?)? Yes (The section "Troubleshooting issues after restoring your site")
Have I searched the tickets before posting? Yes
Have I read the documentation before posting (which pages?)? No
Joomla! version: 1.5.20
PHP version: 5
MySQL version: 5.5.23
Host: www.hostgator.com
Akeeba Backup version which took the backup: 3.3.b1
Kickstart version used to extract the backup: 3.5.2

Description of my issue:
I used Akeeba Backup to migrate my site to another host. The site has been restored successfully. However, I have some issues with the restored site. First of all, if Search Engine Friendly URLs is set to Yes in the site's global configuration, the templates work only for the front page. All other pages appear as if there is no template at all. I tried several different templates installed on the site, the result is always the same. Secondly, I cannot install any new template or other extension, I get an error message: "JFolder::create: Could not create directory. Warning! Failed to move file.".
I tried to move the site twice, first with Kickstart and second time using Site Transfer Wizard. Both times the result is the same.
The URL of the moved site is: http://gator608.hostgator.com/~syportal/
The original site is: http://www.sahajayogaportal.org/

nicholas
Akeeba Staff
Manager
Hello Lev,

You are using a "temporary URL" to access your site, i.e. a URL in the format http://www.example.com/~username. This is incompatible with SEF URLs. It has nothing to do with Akeeba Backup, it's the way Apache (the web server) works. The only workaround is assigning a proper domain name to your site before you can use SEF URLs. This is a frequently asked question and put as item #7 in Kickstart's initial dialogue ("Things you should know about Kickstart"):
7. Trying to restore to the temporary URL of a cPanel host (e.g. http://1.2.3.4/~username) will lead to restoration failure and your site will appear to be not working. This is normal and it's just how your server and CMS software work.
There is also a ticket from last year where I detail what's going on and a possible workaround.

Regarding the installation problems, this is a permissions issue. You will have to check your temporary directory and enable Joomla!'s FTP feature. For more information please look under the "Checking your temporary directory" and "Enable FTP" headers of our generic installation troubleshooting page. Please note that even though the troubleshooting page talks about Akeeba Backup, the same troubleshooting steps apply for the installation of any extension written by any developer.

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

user66965
Thank you, Nicholas. I've solved the second problem. As for the first one, when creating this site I was also using a temporary URL and did not encounter anything like that. I have also another site on Host Gator, which I was creating under a similar temporary URL and again did not encounter such a problem. I only had to set "Use Apache mod_rewrite" to No, but Search Engine Friendly URLs were working. Anyway, probably I'll have to change the DNS records and what will happen.

nicholas
Akeeba Staff
Manager
Hm, just an idea: check that you have a .htaccess file. If not, copy Joomla!'s htaccess.txt to .htaccess and retry. If you already have a .htaccess file you will see a line like this:
#RewriteBase /
Change it to read
RewriteBase /~syportal
It may or may not work; when using temporary URLs your mileage may seriously vary.

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

user66965
I've just tried, it did not work. The site did not open at all. So, the last chance seems to be to update DNS records. Hope that will solve the problem

nicholas
Akeeba Staff
Manager
When you say "the site did not open at all" what do you mean? Blank page? Error page? Something else?

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

user66965
Erro page. 404, "page not found".

nicholas
Akeeba Staff
Manager
All right, that's what I understood but I had to check. You definitely have to set up a domain name. When you do, change that line back to
RewriteBase /
for the SEF URLs to work properly.

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

Support Information

Working hours: Typically we work Monday to Friday, 9am to 7pm Cyprus timezone (EEST). Support is provided by the same developers writing the software, all of which live in Europe. You can still file tickets, but we cannot respond to them, outside of our working hours.

Support policy: We would like to kindly inform you that when using our support you have already agreed to the Support Policy which is part of our Terms of Service. Thank you for your understanding and for helping us help you!

Summer vacations: Our support will be closed for replies and new tickets from August 6th to August 21st, 2022 due to summer vacations.