Support

Site Restoration

#13567 umlaute utf-8 idevaffiliate

Posted in ‘Site restoration’
This is a public ticket

Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.

Environment Information

PHP version
n/a
CMS Type
Other
CMS Version
n/a
Backup Tool Version
n/a
Kickstart version
n/a

user67836
Mandatory information about my setup:

Have I read the related troubleshooter articles above before posting (which pages?)? yes
Have I searched the tickets before posting? yes
Have I read the documentation before posting (which pages?)? yes
Joomla! version: (2.5.7)
PHP version: (5.3.18)
MySQL version: (unknown)
Host: (schlei-media.de)
Akeeba Backup version which took the backup: (latest)
Kickstart version used to extract the backup: (3.5.6)

Description of my issue:

umlaute like äüö in idev affiliate makes Problems. Restored DB from other Backup and now it is good. please fix Restore idevaffiliate DB bug?


also. No admin Email adress passed to the Kickstart pro
no User is availaible.

My site : www.cmm-vital.de
two screenshots atached

nicholas
Akeeba Staff
Manager
Regarding iDevAffiliate: I regret to inform you that AkeebaBackup.com is not the developer of iDevAffiliate or affiliated in any way with its developers. We cannot address issues in third party software, therefore we cannot fix iDevAffiliate as you requested.

If the problem occurred only after restoring the archive, please make sure that iDevAffiliate is set up to use Unicode (actually, UTF-8) in both its database tables and its pages. Akeeba Backup is designed to work only with modern database schemas based on UTF-8. If this is the case and you still get a problem with the restored tables please make sure that the default collation of your database is set to utf8_general_ci as explained in our documentation.

Regarding email: Please note that Kickstart only extracts the archive, it doesn't perform the restoration, as explained in the first screen (popup) displayed every time you run Kickstart. The restoration is performed by the Akeeba Backup Installer (ABI) script which is embedded inside your archive at backup time. What you experience is consistent with an incompatibility issue between ABI and Joomla! 2.5. I can tell you if this is the case should you mention the Akeeba Backup Installer version which is printed in bold, big letters at the very top of the page, just above the top area of your screenshot.

If it reads 3.6.1 or later you have a different issue, namely that your Super Administrators do not belong to user group #8 (the default Joomla! Super Administrator group). This is a limitation of ABI. It cannot detect Super Administrators belonging to different groups as this would require an excessive amount of time and memory, leading to restoration failure. However, even if you do not change this information during restoration (i.e. the field is unavailable, like in your case) you can still restore the backup just fine.

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

Support Information

Working hours: Typically we work Monday to Friday, 9am to 7pm Cyprus timezone (EEST). Support is provided by the same developers writing the software, all of which live in Europe. You can still file tickets, but we cannot respond to them, outside of our working hours.

Support policy: We would like to kindly inform you that when using our support you have already agreed to the Support Policy which is part of our Terms of Service. Thank you for your understanding and for helping us help you!

Summer vacations: Our support will be closed for replies and new tickets from August 6th to August 21st, 2022 due to summer vacations.