Support

Site Restoration

#14029 PHP Version >=5.2.7 error

Posted in ‘Site restoration’
This is a public ticket

Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.

Environment Information

PHP version
n/a
CMS Type
Other
CMS Version
n/a
Backup Tool Version
n/a
Kickstart version
n/a

eecvogi
Mandatory information about my setup:

Have I read the related troubleshooter articles above before posting (which pages?)? Yes
Have I searched the tickets before posting? Yes
Have I read the documentation before posting (which pages?)? Yes
Joomla! version: 2.5.7
PHP version: (5.3.6)
MySQL version: (unknown)
Host: Greatnet
Akeeba Backup version which took the backup: (unknown)
Kickstart version used to extract the backup: 3.3.1

Description of my issue: From then to now I had a error where I couldnt display any page anymore. Nevermind I just deleted the whole website and wanted to restore it with a old backup I did.

Uploading my backup.zip + kickstart.php + de-DE.kickstart.ini.
Going onto my homepage/kickstart.php and unzipping my backup.zip.
Everything works fine till now but when its showing up all information about php version, mysql and so on it shows: PHP Version >=5.2.7 NO

I cant continue, cause of this error and I also dont know what to do next. I just contacted my provider to ask them for fixing this problem. They told me how to define a php version. I followed their instrcutions and had no error but nothing changed either, so I still got this error.


I hope someone of you can help me to fix this error. :D

UPDATE: Picture in attachment is not working. Please Check this link: http://file1.npage.de/002016/94/bilder/backup.png

I also got a error updating akeeba. It displays to install the Update manual but always when I try to install it manual it shows a error that the .xml file could not be found.

nicholas
Akeeba Staff
Manager
PHP is reporting to the installation script (Akeeba Backup Installer) that the PHP version is less than PHP 5.2.7. Most likely you need to enter something in your .htaccess file to force the use of PHP 5.3 as the default PHP version on your site. Here's the thing. When Kickstart runs, it will rename the .htaccess file. Therefore you'll need to do something like this:
  1. Run Kickstart
  2. Runt the archive extraction, up to the point you see the "Run the Installer" button. Don't click on it yet!
  3. Create the .htaccess which defines PHP 5.3 as your default PHP version
  4. Click on the "Run the Installer" button and go on with the restoration.
  5. After the last page appears, do not close Akeeba Backup Installer's window yet.
  6. Remove your .htaccess file
  7. Close Akeeba Backup Installer's window and click on the Clean Up button
  8. Check the .htaccess file and add the necessary lines to choose PHP 5.3 as the default PHP version to the bottom of the file

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

eecvogi
Thanks for your fast reply. I need to delete all and upload it again. After I will follow your instructions and give you a feedback.

nicholas
Akeeba Staff
Manager
FLOODING; TICKET CLOSED AS PER TERMS OF SERVICE.

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

Support Information

Working hours: Typically we work Monday to Friday, 9am to 7pm Cyprus timezone (EEST). Support is provided by the same developers writing the software, all of which live in Europe. You can still file tickets, but we cannot respond to them, outside of our working hours.

Support policy: We would like to kindly inform you that when using our support you have already agreed to the Support Policy which is part of our Terms of Service. Thank you for your understanding and for helping us help you!

Summer vacations: Our support will be closed for replies and new tickets from August 6th to August 21st, 2022 due to summer vacations.