Support

Site Restoration

#15616 Database restoration - An error occurred while restoring the database.

Posted in ‘Site restoration’
This is a public ticket

Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.

Environment Information

PHP version
n/a
CMS Type
Other
CMS Version
n/a
Backup Tool Version
n/a
Kickstart version
n/a

user64737
Mandatory information about my setup:

Have I read the related troubleshooter articles above before posting (which pages?)? Yes
Have I searched the tickets before posting? Yes
Have I read the documentation before posting (which pages?)? No
Joomla! version: (2.5.9)
PHP version: (5.3.21)
MySQL version: (5.1.68 cll)
Host: (hostingplan.net)
Akeeba Backup version which took the backup: (Akeeba Backup Professional 3.7.4)
Kickstart version used to extract the backup: (Kickstart Pro-3.5.2)

Description of my issue: After the latest Akeeba update with Angie I can't run Kickstar to the end.
It stops on the new interface Angie at the " Restoration of site's main database "
I have the following issue:
****************************************************************************************************************************
Database restoration

An error occurred while restoring the database. The error message can be found below. Click on the × button at the top right of this dialog message to close it and return to the database restoration page.

SQL=DROP TABLE IF EXISTS `jxew2_admintools_acl`
****************************************************************************************************************************
I usually make a weekly backup on the working site then I run tha backup on my local site to check if everything is fine but can't do it anymore after this latest Akeeba Backup Professional 3.7.4 update.
Please note I ran both on Mac and PC and got the same issue, on Mamp and Wamp on two different machines: a Macbook Pro and an iMac.

Please note I usually delete the database using PHP MyAdmin before running Kickstart Pro

Franco

nicholas
Akeeba Staff
Manager
Please ask your host to give your database user the DROP, CREATE and ALTER privileges for the tables in your database.

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

nicholas
Akeeba Staff
Manager
PS: Since this is your local machines, please go to phpMyAdmin and make sure that you give your database user all the privileges you can see listed in phpMyAdmin. You don't need all of them, but this is by far the easiest way to get your local sites restored.

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

user64737
Hi Nicholas

I have on my local testing server the users set to " All Privileges "

I just double checked updating another joomla site
to the latest Akeeba Pro and Admin Tool Pro
made a backup, downloaded and got the same problem while restoring
it stops at: admintools_acl

Franco

nicholas
Akeeba Staff
Manager
Which browser and operating system are you using? I need both the name and version of each one.

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

user64737
Macbook Pro 15" 2009

Mac OSX 10.7.5
Firefox 19.0.2

nicholas
Akeeba Staff
Manager
Can you please try using Safari or Google Chrome? I have a very strong suspicion that Firefox doesn't work reliably. I've had other similar reports and everyone's using Firefox – a browser which I stopped supporting a few months ago because of it inconsistent Javascript behaviour.

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

user64737
Nicholas you right Firefox acts weird at least with the latest versions
so I' ve just tryed to run the script with these browsers but unfortunatly with the same issue:

Opera 12.02
Google Chrome Versione 26.0.1410.43
Safari 6.0.2

Franco
ps: checked on Mac OS later I will check on Windows 7 with the browser I got
wich I have on another partition

nicholas
Akeeba Staff
Manager
Please try running the installation by directly accessing http://www.example.com/installation/index.php where www.example.com is your site. In the first page click on the red button in the toolbar, labelled "Start Over". For good measure please delete the files inside the installation/tmp directory as well. Then reload the installer's page and retry. According to my experience this usually works. If it doesn't, please post back.

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

user64737
Nicholas I've followed your advice

but unfortunately got the same issue, it stops at the database restoration routine with the same message, so to be shure I made a backup of another site which is on a different server and tried to restore it on my local server but with the same result.
The only way I could make it working was:
1) - to run Kickstart to extract the site on my local server
2) - download the database from the remote server
3) - move the remote database to the local with phpMyAdmin
This is the only way up for now

Franco

nicholas
Akeeba Staff
Manager
Does that table exist after the restoration of the site?

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

user64737
Yes it does: xgeun_admintools_acl`
as on the remote server after transferring it on the local while running Kickstart does not create the whole database at all.

nicholas
Akeeba Staff
Manager
I still cannot reproduce this issue, even with very large databases (like this site's) :s I know it's not a browser issue, because I'm using and testing with the same browsers as you. I know it's not the PHP version because that's also what I'm using. I honestly can't think what could be going wrong, except a session issue. So maybe I'm shooting in the dark, but that's the next thing I'm going to try in the new version of Akeeba Backup: not using PHP's session storage at all.

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

user64737
Ok Nicholas

for your convenience I've googled with:
"Akeeba Database restoration
An error occurred while restoring the database. The error message can be found below. Click on the × button at the top right of this dialog message to close it and return to the database restoration page."
Found something similar on a french site: http://www.saintbauzilledeputois.fr/installation/index.php?view=database
And on an italian forum:
http://forum.joomla.it/index.php?topic=161648.0
Please look at the latest post " stefano954 " if this may help you.

Thanks Franco

nicholas
Akeeba Staff
Manager
That's a completely different issue, resulting from wrong database credentials.

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

user64737
Hi Nicholas
I've just found it was my mistake I didn't realize that now with Angie we have to fill the database restoration form with username, password, database name etc. The previous script didn't need it.
Now everything works fine. Thanks for your time.

nicholas
Akeeba Staff
Manager
You're welcome!

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

Support Information

Working hours: Typically we work Monday to Friday, 9am to 7pm Cyprus timezone (EEST). Support is provided by the same developers writing the software, all of which live in Europe. You can still file tickets, but we cannot respond to them, outside of our working hours.

Support policy: We would like to kindly inform you that when using our support you have already agreed to the Support Policy which is part of our Terms of Service. Thank you for your understanding and for helping us help you!

Summer vacations: Our support will be closed for replies and new tickets from August 6th to August 21st, 2022 due to summer vacations.