Support

Site Restoration

#15633 Archive not extracting correctly

Posted in ‘Site restoration’
This is a public ticket

Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.

Environment Information

PHP version
n/a
CMS Type
Other
CMS Version
n/a
Backup Tool Version
n/a
Kickstart version
n/a

user53984
Mandatory information about my setup:

Have I read the related troubleshooter articles above before posting (which pages?)? Yes
Have I searched the tickets before posting? Yes
Have I read the documentation before posting (which pages?)?Yes
Joomla! version: 3.0.3
PHP version: 5.3.10
MySQL version: 5.1.68
Host: inmotionhosting
Akeeba Backup version which took the backup: (unknown), i believe its the latest version
Kickstart version used to extract the backup: (unknown), i believe its the latest

Description of my issue:

So I ran a kickstart backup and extract but now my site is not functioning correctly. I am getting 505 errors. Also the last step of the kickstart process was not able to complete for some reason. It would just give me a 505 when I clicked it. Although the site works I get errors when trying to access certain extensions like akeeba or the extensions directory. This is a big problem and I need help fixing it. It is urgent since I can't install new extensions and I don't want to make changes to the site incase I need to go to a backup again. Can you please run the restore for me and see what is going on?

nicholas
Akeeba Staff
Manager
Are you perfectly sure the error code is 505?! HTTP 505 means that your web server cannot serve the HTTP protocol version requested by the browser which means that the web server is out of date. If you meant 500 instead of 505, it's a completely different issue. Please specify which error code you get.

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

user53984
Its saying that certain components are missing. My guess is that the extraction did not work correctly and I tried it a few times. Can I gave you access to the site to take a look?

nicholas
Akeeba Staff
Manager
Is it possible to give me a little more details? Right now I have no idea what you're seeing, let alone how to reproduce that even if I'm given access to the site. Which components throw which error?

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

user53984
Basically when I ran the extract I got through all the steps in the install process except for the last one. I dont remember what step it was but it basically just errors out. Now when I go to the admin part of the site and log in and try and use the following components I get a 505 error.

option=com_akeeba


HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request. The website encountered an error while retrieving http://www.***.org/administrator/index.php?option=com_akeeba. It may be down for maintenance or configured incorrectly.




When I click on the admin tools component I get this error http://www.***.org/administrator/index.php?option=com_admintools


Fatal error: Call to a member function get() on a non-object in /home/***/public_html/administrator/components/com_admintools/models/masterpw.php on line 35


When I click extensions I get this error


The website encountered an error while retrieving http://www.***.org/administrator/index.php?option=com_installer. It may be down for maintenance or configured incorrectly.

Here are some suggestions:

Reload this webpage later.

HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.


The archive is extracted fine and installs fine until the very last step in the installer which does not complete. I can still access the site but I get errors when trying to use certain components or system files so something is broken.

nicholas
Akeeba Staff
Manager
Did you restore your site on top of an existing site which was using a previous version of Joomla! and/or any of my extensions?

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

user53984
I did restore on top of a previous site I think although I don't remember. It was only a week older and was corrupted so I did the restore.

nicholas
Akeeba Staff
Manager
When you restore a backup on top of an existing site the existing site's files are not removed. This can cause extensions to be broken, especially if they are a different version than the ones in the backup (or if the Joomla! version differs). In order to fix that you have to delete all files and folders from your site and redo the restoration afresh.

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

System Task
system
This ticket has been automatically closed. All tickets which have been inactive for a long time are automatically closed. If you believe that this ticket was closed in error, please contact us.

Support Information

Working hours: Typically we work Monday to Friday, 9am to 7pm Cyprus timezone (EEST). Support is provided by the same developers writing the software, all of which live in Europe. You can still file tickets, but we cannot respond to them, outside of our working hours.

Support policy: We would like to kindly inform you that when using our support you have already agreed to the Support Policy which is part of our Terms of Service. Thank you for your understanding and for helping us help you!

Summer vacations: Our support will be closed for replies and new tickets from August 6th to August 21st, 2022 due to summer vacations.