Support

Site Restoration

#14495 kickstart stuck on PHP Version >=5.2.7 error

Posted in ‘Site restoration’
This is a public ticket

Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.

Environment Information

PHP version
n/a
CMS Type
Other
CMS Version
n/a
Backup Tool Version
n/a
Kickstart version
n/a

DCS-Online

Mandatory information about my setup:

Have I read the related troubleshooter articles above before posting (which pages?)? Yes
Have I searched the tickets before posting? Yes
Have I read the documentation before posting (which pages?)? Yes
Joomla! version:2.5.8
PHP version: 5.2.6-1
MySQL version: 5.0.51a-24+lenny5
Host: (optional, but it helps us help you)
Akeeba Backup version which took the backup: 3.6.10
Kickstart version used to extract the backup: pro 3.6.0

Description of my issue: If I extract my backup and want to start the restoration. Kicksart is stuck on the check php version PHP Version >=5.2.7 error.

I hear you think yes ofcourse  you're running php 5.2.6-1, but if I follow the kickstart link to explain the why its not working. It says its just a joomla check if joomla has found al the reqirements, but if I install joomla (2.5.8) it installs fine?

#14029: PHP Version >=5.2.7 error   did not help..

TIA

nicholas
Akeeba Staff
Manager

The first thing I have to point out is that what you see is NOT Kickstart. People, please DO read the first page (popup) displayed by Kickstart every single time it runs. The restoration script is Akeeba Backup Installer, as demonstrated by its title in big, bold letters at the top of the page. Kickstart merely extracts the archive. Kickstart and Akeeba Backup Installer are as related to each other as flour and sugar. Yes, if you combine both you can make a cake. But is sugar some kind of flour? Not at all.

Why doesn't Akeeba Backup Installer work on anything lower than PHP 5.2.7? Because only PHP 5.2.7 and later is supported by our software. This has been the case for a very, very long time.

To put things in perspective. PHP 5.2 has been end of life since January 2011. That's less than two weeks sort of two years. End of life means obsolete. Not supported by its developers. Dead as a dodo. The last version was PHP 5.2.17. PHP 5.2.6 was released over 5 years ago. In computer terms that's ancient. Should you use a five year old version of PHP? Not unless you enjoy being hacked, when anything works at all. The earliest version of PHP we support is PHP 5.2.7, which is a little younger than 5 years old and has been dead for two years. Please, if you have a server with software older than that then it's more than two years overdue for an upgrade. FWIW, we will drop support for PHP 5.2 in 2013. Besides the obvious security implications of using an end of life release of PHP there are also technical issues. At some point continuing to support PHP 5.2 makes it impossible to maintain and evolve the software. Do yourself a favour. Don't use a server with ancient software.

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

DCS-Online

First thanks for the very quick reply!!

second guess I didn't searched deep enough sory for that...

The server is going to be updated in the comming months, just was updating the sites already (local) to J2.5, and was testing if it was working fine on a live server.

Wil use an old version of Akeeba for that.

Just my thought I was confused by the link Akeeba Backup Installer gave me explaining it was a pure Joomla check fault, and Joomla installed fine, so maybe the above explanation in the link provided, no critics trying to help...

Appie

nicholas
Akeeba Staff
Manager

Hi Appie,

 

Yes, you are right. These checks at the top are Joomla! checks except the PHP version check.  I had to choose between the following:

  1. Joomla! 2.5 runs on PHP 5.2.4 or later
  2. Akeeba Backup Installer runs on PHP 5.2.7 or later
  3. Joomla! 3.0 runs on PHP 5.3.3 or later

I had to make a check which would be the best compromise. Since no restoration will happen if Akeeba Backup Installer doesn't run, I had to satisfy #2 (which also satisifies #1). If I chose to satisfy #3 then you wouldn't be able to restore J! 2.5 backups on servers compatible with ABI and J! 2.5. So I chose to check for PHP 5.2.7 or later. I could try to explain that in the documentation, but I thought that would be a little more confusing, isn't it?

Nicholas K. Dionysopoulos

Lead Developer and Director

🇬🇷Greek: native 🇬🇧English: excellent 🇫🇷French: basic • 🕐 My time zone is Europe / Athens
Please keep in mind my timezone and cultural differences when reading my replies. Thank you!

Support Information

Working hours: Typically we work Monday to Friday, 9am to 7pm Cyprus timezone (EEST). Support is provided by the same developers writing the software, all of which live in Europe. You can still file tickets, but we cannot respond to them, outside of our working hours.

Support policy: We would like to kindly inform you that when using our support you have already agreed to the Support Policy which is part of our Terms of Service. Thank you for your understanding and for helping us help you!

Summer vacations: Our support will be closed for replies and new tickets from August 6th to August 21st, 2022 due to summer vacations.